FAQ – Need help? -  Consult Frequently Asked Questions

What are the minimum system requirements for iCADMac?

Apple® Mac® Pro MacBook® Pro; iMac®; Mac® mini; MacBook Air®; MacBook®

  • MacOS X v10.14 (Mojave), v10.15 (Catalina), o v11.0 (Big Sur)
  • x64 Intel® and Apple M1 processors processor
  • 4 GB of RAM (8 GB recommended)
  • 4 GB free disk space for download and installation (6 GB recommended)
  • All graphics cards on supported hardware
  • 1,366 x 768 display with true color
  • Mac OS X-compliant printer
iCADMac shows an appreciable mouse lag (slow movement)

Under some circumstances, on iMac and MacBook, iCADMac shows the mouse lag at the crosshair and we also noticed that the mouse movement could be very slow. It's possible to correct this behavior by switching to the Mac-style mode. To perform it, click on the "Window" menu, select "Switch to UI mode" and answer Yes in the command bar. Restarting the software, the new configuration will be applied. Note that with the Mac style toolbar mode the toolbars are placed inside the Tool Matrix palette, yet the user can easily move them where he prefers on the screen area

How to change the background color of the drawing area?

From the "Format" menu select "Drafting Options", choose "System Options" in the left panel, expand "Display" menu and then expand "Element Colors". In this section you can customize all the elements of the interface. Choosing "Model Background" from the list you can customize the background color of the drawing area.

At startup iCADMac doesn't run displaying an error

At startup the software doesn't run showing the following message:

Dyld Error Message:
Library not loaded: /usr/X11/lib/libfontconfig.1.dylib
Referenced from: /Applications/iCADMac.app/Contents/MacOS/../Frameworks/libDDKERNEL.1.dylib
Reason: image not found

SOLUTION: Check if you are working with the latest version of iCADMac. The last version guarantees full compatibility with all the versions of Mac OSX (see also System requirements).
In order to get the latest version of iCADMac, visit the download section of our website www.icadmac.com or contact our technical support at support@icadmac.com

PDF files are not converted from the Add-ons module

Check if you are working with the latest version of iCADMac. The last version guarantees full compatibility with all the versions of Mac OSX (see also System requirements). In order to get the last available version of iCADMac, visit the download section of our website www.icadmac.com or contact our technical support at support@icadmac.com

How to switch to the Mac style toolbar mode

With iCADMac it is possible to work in the Fixed-style toolbar mode (like the classic AutoCAD® stile) or in the Mac style toolbar mode. To switch between these modes, click on the "Window" menu, select "Switch UI mode" and digit "Yes" in the command bar. Then restart the software in order to apply the new configuration. In the Mac style toolbar mode the toolbars are placed inside the Tool Matrix palette.

My trial version of iCADMac doesn't allow printing

By registering your trial version of iCADMac, you will enable the iCADMac full functionalities for 30-days. In order to register your trial version of iCADMac, follow these steps:

  • Run iCADMac
  • Press the ACTIVATE button
  • Select the QUICK ACTIVATION option in the second dialog
  • Select activation via INTERNET
  • Please complete the form and press the NEXT button
  • Select TIME-LIMITED TRIAL VERSION  (non-restrictive)

The non-registered trial version is not time limited but misses some functionalities.

My trial version of iCADMac doesn't allow me to copy and paste

By registering your trial version of iCADMac, you will enable the iCADMac full functionalities for 30-days. In order to register your trial version of iCADMac, follow these steps:

  • Run iCADMac
  • Press the ACTIVATE button
  • Select the QUICK ACTIVATION option in the second dialog
  • Select activation via INTERNET
  • Please complete the form and press the NEXT button
  • Select TIME-LIMITED TRIAL VERSION  (non-restrictive) 

The non-registered trial version is not time limited but misses some functionalities.

My trial version of iCADMac doesn't allow me to export

By registering your trial version of iCADMac, you will enable the iCADMac full functionalities for 30-days. In order to register your trial version of iCADMac, follow these steps:

  • Run iCADMac
  • Press the ACTIVATE button
  • Select the QUICK ACTIVATION option in the second dialog
  • Select activation via INTERNET
  • Please complete the form and press the NEXT button
  • Select TIME-LIMITED TRIAL VERSION  (non-restrictive) 

The non-registered trial version is not time limited but misses some functionalities.

Where can I find the commands toolbars?

By default you can find the main toolbars (Layer, Property, Styles, Drawing and Edit) directly anchored to the top or left side of the software interface. On the right side, instead, you can find the property and Tool Matrix palettes which contains all the other command toolbars. In order to show them you simply need to click on the Tool Matrix button placed at the bottom of the property palette.

You can customize all the interfaces as you need. All the toolbars can be easily dragged inside the drawing area and then anchored where you want. In the "Format" menu you can also find the command "Toolbar" that allows you to show the toolbars you most frequently work with or hide those you don't need. NOTE: Have a look at the online Help (F1) for more information about the User Interface customization.

How to use a multi-monitor configuration

From the "Window" menu select "Switch UI Mode" and digit "Yes" in the command bar. Restart iCAMac in order to apply the new configuration. In the floating mode all toolbars can be placed inside the Tool Matrix palette.

How can I reset menus and interface to the initial default configuration?

All the iCADMac configurations are stored in the "iCADMac" folder inside the User Library/Preferences folder. By moving this folder to trash, iCADMac will reset all the menus and toolbars. NOTE! This operation will delete all your customization on toolbars and menus.

How to completely remove iCADMAc from my Mac

As for most Applications, in order to remove iCAMac you simply need to move it to trash and delete the user's preferences folder. You can find it inside the user's Library/Preferences folder.

Can I edit more than one grip at once?

Yes, you can do that. Select all the entities you want to modify, press and hold the SHIFT button and with the left mouse click select the grips you want to edit.

How can I save my printing configuration?

For the correct management of prints, we suggest that you use the function "Page Layout Manager" from the File menu. Using this function, it is possible to pre-configure different printing setups for the active drawing and also to import new setups from other drawings.